Operadores Relacionais no VisuAlg

Nas aulas anteriores já aprendemos sobre variáveis e operadores aritméticos no VisuAlg, inclusive fizemos alguns exercícios bem legais de Lógica.

Hoje vamos aprender a aplicar os operadores lógicos:

 

Operadores Relacionais

São eles;

= igual
< menor que
> maior que
<= menor ou igual que
>= maior ou igual que
<> diferentes de

As operações com operadores relacionais sempre retornam um valor FALSO ou VERDADEIRO.

Por exemplo:

O número 5 é maior que o número 6? FALSO
O número 5 é menor que o número 6? VERDADEIRO

 

Exemplo de um programa de computador usando Operadores Relacionais

Agora vamos ver um exemplo de programa de computador que faz comparações entre dois números.

Algoritmo "Teste Lógico"
Var
numero1: inteiro
numero2: inteiro

Inicio

escreval("Olá usuário!")
 escreval("Digite um número: ")
 leia (numero1)
 escreval("Digite outro número: ")
 leia (numero2)
 
 escreval("")
 escreval("*************************************************** ")
 escreval("**** Agora vamos comparar os números digitados **** ")
 escreval("*************************************************** ")
 escreval("")
 
 //pimeiro teste usando o operador relacional =
 escreval(numero1, " é igual a ", numero2, "?")
 escreval(" Resposta: ", numero1 = numero2)
 escreval("")

//segundo teste usando o operador relacional <
 escreval(numero1, " é menor que ", numero2, "?")
 escreval(" Resposta: ", numero1 < numero2)
 escreval("")
 
 //terceiro teste usando o operador relacional >
 escreval(numero1, " é maior que ", numero2, "?")
 escreval(" Resposta: ", numero1 > numero2)
 escreval("")

//quarto teste usando o operador relacional <=
 escreval(numero1, " é menor ou igual que ", numero2, "?")
 escreval(" Resposta: ", numero1<= numero2)
 escreval("")

//quinto teste usando o operador relacional >=
 escreval(numero1, " é maior ou igual que ", numero2, "?")
 escreval(" Resposta: ", numero1 >= numero2)
 escreval("")
 
 //sexto teste usando o operador relacional <>
 escreval(numero1, " é diferente de ", numero2, "?")
 escreval(" Resposta: ", numero1 <> numero2)

Fimalgoritmo

O resultado será este

E quando não são números?

Podemos usar operadores lógicos para testar valores literais também, neste caso, prevalece a ordem alfabética dos textos digitados pelo usuário.

 

Condicionais (Se / Senão)

Uma condicional é um desvio de um programa de computador, aonde o computador somente executará determinada ação após testar se ela é VERDADEIRA ou FALSA

No VisuAlg, um condicional pode ser escrito da seguinte forma;

se (<condição>) entao 
 <comandos da condição verdadeira>
senao
 <comandos da condição falsa>
fimse

Exemplo de um programa de login

Neste exemplo o usuário tem que acertar a senha do programa que deve ser Sergio. Se o usuário digitar a senha Sergio

Algoritmo "Login"

Var
senha:caracter

Inicio

escreval("Digite a senha")
leia(senha)

se (senha = "Sergio") entao
 escreva("A senha está correta!")
senao
 escreva("A senha está errada!")
fimse

Fimalgoritmo

Veja o resultado:

Entenda o Código

O algoritmo acima testa se a senha é igual a “Sergio”, se a condição senha = “Sergio” for verdadeira, então o programa entende que deverá mostrar a mensagem “A senha está correta!”

Caso a senha não seja “Sergio”, o programa entende que é uma condição falsa e então ele exibe a mensagem “A senha está errada!”

Deixe seu comentário