Estrutura de repetição no VisuALG – Enquanto

A sintaxe da estrutura enquanto no VisuALG é

enquanto <expressão-lógica> faca
   <seqüência-de-comandos>
fimenquanto

Este é um algorítimo que resolve 3 exemplos mostrados na aula;

Algoritmo "Exemplos de laçoa de repetição usando o ENQUANTO"

Var
num, n, idade:inteiro
soma:real;
nome:caractere;

Inicio

// EXIBIR OS 100 PRIMEIROS NÚMEROS.
escreval("Exibir os 100 primeiros números")
num <- 0
enquanto (num <= 10) faca
 escreval(num)
 num <- num + 1
fimenquanto

// CALCULO DA MÉDIA.
escreval("*****************************")
escreval("Calcular a média de 5 números")
num <- 0
enquanto (n<5) faca
 escreva("Digite um número: ")
 leia (num)
 soma <- soma + num
 n <- n+1
fimenquanto
escreval("Média = ", soma/5)

// VERIFICA A MAIORIDADE DE 5 PESSOAS
escreval("*****************************")
escreval("Verificar maioridade de 5 pessoas")
n <-0
enquanto (n<5) faca
 escreva("digite o nome do aluno:")
 leia(nome)
 escreva("digite a idade:")
 leia(idade)
 
 se (idade < 18) entao
 escreva(nome, " você é menor de idade")
 senao
 escreva(nome, " você é maior de idade")
 fimse
fimenquanto
Fimalgoritmo

Deixe seu comentário